
to-do list in JOSM

Figure 1: to-do list in JOSM

5.1 Data Cleaningwith JOSM
This section provides:

• An overview data cleaning tools in JOSM
• Step-by-step instructions for importing field data into JOSM
• Step-by-step instructions for cleaning data into JOSM

The following materials are designed to assist project managers and others leading trainings and work-
shops. However, this material is also suitable for individuals interested in learning how to clean and up-
load field data in JOSM.

Overview
Data collected in the field should always be cleaned for errors and rectifiedwith existingOSMdata before
upload. There are a lot of OSM data editors available, but in this module the OSM data editor used is
JOSM.JOSMhasa lot of useful tools andplugins,makingOSMmappinga lot easier butmost importantly,
it is the easiest tool and best tool for maintaining quality OSM data while importing batches of field data
into OSM.

JOSMData Cleaning Tools

Thereare toolsbuilt intoJOSM,aswell asadditional plugins that canassistwithdataquality control during
the upload process.

• Filters is a built-in tool that allows you to disable, hide, select, and highlight specific groups of ob-
jects based on flexible custom parameters. This tool will help you to spot and avoid common mis-
takes, and review data.

• TheValidation Tool is another built-in tool that will review and search for common errors as well as
provide warnings about potentially problematic data.

• TheTodoList plug-in allows users to systematically reviewdata that is to be uploaded, andmonitor
progress of data cleaning work. The “ToDo List” plug-in, needs to be downloaded before it can be
used. Visit this page to learn how to install plug-ins in JOSM, then download the “ToDo List” plug-in.

Resources and TrainingMaterials
This section features a selection of resources targeted at projectmanagers, trainers, or even self-learners
on the topic(s) outlined above.
The following section is designed to serve as self-paced material that can be used both during trainings,
and by self-guided learners.

Adding Survey Data into JOSM

Following a field data collection activity using JOSM, use the following step-by-step guide to clean and
upload data to OSM. By following these steps, you will be able to:

• Install plugin Utilsplugin2
• Merge all survey data
• Save .osm file using JOSM
• Download OSM data
• Add satellite imagery layer on JOSM
• Add and edit OSM data using JOSM
• Upload changes into OSM

• View changes of OSM data in OSMwebsite
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Installing plugin utilsplugin2

Figure 2: Installing plugin utilsplugin2

More tools menu on JOSM

Figure 3: More tools menu on JOSM

Skills and TechnologyNeeded
• Computer
• Internet Connection
• JOSM Installed
• Basic JOSM skills
• Survey data

1. Installing plugin Utilsplugin2
Before adding or editing OSM data using JOSM, install plugin you’ll be using first. JOSM has a plugin
called utilsplugin2 whose one of the functions is makes copying preset/tag easier. To use this plugin,
you have to install the plugin first since it is not installed by default. These are the steps to install plugin
utilsplugin2:

• Open JOSM
• Click menu Edit→Preferences
• SelectmenuPlugins to install newplugin. If youhaven’t downloadedavailableplugins, clickDown-
load List first to download it. Make sure that you are connected to the internet.

• After downloading plugins, search the utlisplugin2 by typing it in the search box. After you found it,
give a check on the checkbox next to utilsplugin2.

Installing plugin utilsplugin2
• Click OK and wait until the installation process is finished. If the plugin has successfully installed,
there will beMore toolsmenu on your JOSM.

More tools menu on JOSM
Note: Sometimes JOSM ask you to Restart JOSM after installing new plugin to apply newly
installed plugins. However, not all newly installed plugin needs JOSM restarting to be used
after installation process finished.

2. Importing Field Data
2.1 Merging OMK Survey Data *Note: if your data is in a different format, skip to b. Importing Survey
Data (non-OMK).
If you have finished conducting survey using field data collection toolkit such as ODK Collect and Open-
MapKit, you can use the survey data as the reference to add object’s informationwhenmapping it inOSM.
Survey data file format fromOpenMapKit is .osm. The number of .osm files fromOpenMapKit will be the
sameamount as thesurveyedobjects since informationof oneobjectwill besaved inone .osmfile. Merge
all .osm file to make it easier to use the survey data as mapping reference by following these steps:

• Go to File Explorer to where you save .osm file fromODKCollect andOMK.
File directory for .osm file fromODKCollect

• Search all .osm file by typing “osm” in the Search box. Select all .osm file from the search results.
Search results for keyword “osm”

• Drag all selected .osm file to JOSM.

File directory for .osm file fromODKCollect

Figure 4: File directory for .osm file fromODKCollect

2



Search results for keyword “osm”

Figure 5: Search results for keyword “osm”

LayersWindows after .osm file fromODK and OMK dragged into JOSM

Figure 6: LayersWindows after .osm file fromODK and OMK dragged into JOSM

LayersWindows after .osm file fromODK and OMK dragged into JOSM
• Select all those .osm layer by selecting theuppermost .osm layer, thenpressingShift and then
selecting the lowermost .osm layer

• Right click on one of the .osm layer, then clickMerge. Select target layerWindowswill appear,
you do not have to change the target layer, clickMerge.

Merging all survey data layer
• Save the merged layer and change the name by right-clicking on themerged layer, select Save
As, change the layer name and then click Save.

Saving the merged survey data layer
• JOSM provides a plugin named to-do to help you mark the mapped or unmapped object from the
merged survey data layer. You can refer toUsing to-do list onJOSMmodule to learn how to install
and how to use to-doplugin in details. If you have already installed to-do plugin and activated Todo
list Windows, select all objects nodes in themerged layer usingSelect object icon, then clickAdd
on the Todo list Windows.

Adding objects into Todo list
2.2 Importing Survey Data (non-OSM)
You will need to convert your data into a .geojson, .shapefile, or .osm file before beginning data cleaning.
We recommendmerging and converting files in .QGIS, then open the merged file in JOSM.
3. DownloadingOSMData
After successfully merging all survey data, you need to download existingOSMdata. DownloadingOSM
dataaims todiscoverwhichobjectsalreadymappedandwhichobjectshavenotalreadymappedonOSM.
These are the steps to download OSM data using JOSM:

• Click menu File→DownloadData
• DownloadWindowswill appear. It will show you tab SlippyMap by default.

DownloadWindows on JOSM
• If themap is not displaying yourmappingarea, slide themapby rightclickingandhold yourmouse
and thendrag themap to yourmapping area. Drawabox at yourmapping area by left clickingand
hold your mouse and thenmove your mouse until a pink box cover the entire mapping area. Then
clickDownload.

• If it is quitehard tofindyourmappingareabysliding themap, youcanclick tabAreasaroundplaces
and type the name of your mapping area in the Enter a place name to search for box then click
Search. The search result will show you names of your mapping area. Click on one of the names
then go back to tab SlippyMap. The map on the tab SlippyMapwill be directed to your mapping
area. Draw a box covering your entire area of mapping, then clickDownload.
Note: Do mind the amount of existing OSM data in your mapping area. If there is already
a lot of existing data, you should download it part by part since JOSM can not download an
enormous amount of data at once.

Tab “Areas around places” at DownloadWindows

Merging all survey data layer

Figure 7: Merging all survey data layer
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Saving the merged survey data layer

Figure 8: Saving the merged survey data layer

Adding objects into Todo list

Figure 9: Adding objects into Todo list

• After finished downloading OSM data in your mapping area, there will be a new layer in the Layer
Windows that will also be your editing layer to add or edit OSM data. Make sure that you only add
or edit data in the clear area, not in the shaded area. The shaded area is not your downloaded
area. Andmake sure your entire survey area is already downloaded. After downloading OSM data,
your JOSMwill look like this:

Tab “Downloading OSM data on JOSM” at DownloadWindows
• If you already downloadedOSM data in all your area, merge your downloadedOSM data layer with
your surveydata layer. Select those two layers then rightclick, selectMerge. Saveonyour survey
data layer. Then clickMerge.

Merging downloaded OSM data with survey data layer
4. Adding Satellite Imagery

• Add satellite imagery as another reference for mapping by clicking menu Imagery→ choose one
of the available imagery you want to use, such as DigitalGlobe Premium Imagery. After suc-
cessfully adding satellite imagery, it is time to add OSM data. Your JOSMwill look like this:

Adding satellite imagery on JOSM
• You can adjust the display of the satellite imagery. Select the satellite imagery layer, then click icon
Change visibility of selected layer and adjust its display by sliding the blue button left or right.

Changing the display of satellite imagery
• If you use DigitalGlobe Premium Imagery as your reference, sometimes it has two versions of
display when you zoom it in or zoom it out. Usually there is only one version of display aligned with
the existing OSM data. Inactivate Auto Zoom feature so that the satellite imagery display won’t
change when you zoom it in or zoom it out. To inactivate Auto Zoom feature, right click on the
Satellite Imagerydisplay→clickAuto zoom so that the checkmark next to Auto zoomdisappear.

Inactivating Auto zoom for satellite imagery
5. EditingOSMData Using JOSM
Now you are ready to add or to edit OSMdata using JOSM. You can draw new objects or you can edit the
existing objects using the tools mentioned inUsing JOSMmodule. Here are the steps on how to add or
edit OSM data using survey data, downloaded OSM data and satellite imagery that you already added
before on JOSM:

• After successfully following the stepsmentioned in the previous sections, therewill be two layers on
your JOSM: satellite imagery layer (in the picture below, the layermeant is DigitalGlobe Premium
Imagery layer) andmerged survey data with downloaded OSM data layer (in the picture below,
the layer meant is hasil_survey_jakut.osm layer). It will look like this:

Satellite imagery layer andmerged survey data with downloaded data layer
• You can use Filter feature on JOSM so that you don’t accidentally make changes on other objects
such as administrative boundaries. Administrative boundaries in OSM is a delicate objects, so if
there are already administrative boundariesmapped on yourmapping area then it is better to utilize
theFilter feature. To use thisFilter feature, activate the FilterWindows by clickingmenuWindows

DownloadWindows on JOSM

Figure 10: DownloadWindows on JOSM
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Tab “Areas around places” at DownloadWindows

Figure 11: Tab “Areas around places” at DownloadWindows

Downloading OSM data on JOSM

Figure 12: Downloading OSM data on JOSM

→ Filter. There will be Filter Windows in the right panel. Click Add in the Filter Windows, type
boundary=administrative in the Filter string box and click Submit Filter. New filter will appear
for the administrative boundaries. To turn off the filter, simply uncheck the checkmark on the left of
the filter. You can find outmore about Filter feature on JOSM in theUsing Filter on JOSMmodule.

Filter Windows on JOSM
Adding filter string in the Filter Windows
Newly added filter in the Filter Windows

• Start mapping by zooming in to an object, select one object in the Todo list Windows and then click
Zoom. After selecting and zooming in one object, you can copy the tag from the selected object
to the downloaded OSM objects. Select the downloaded OSM object that aligns with the selected
survey object, then clickmenuMore tools→Copy tags fromprevious selection or pressShift +
R on your keyboard. Make sure you selected the aligned survey object right before copying its tags
to downloadedOSMobject. Alsomake sure that the copied tags are consistent withOSMmapping
guidelines and suitable for the object type. For example, in the picture below, a clinic located in
a shophouse complex, mapped as a point and only have tags suitable for point object. While the
building related tags added to the shophouse building where the clinic is located. When you finish
copying tags for one object, click Mark to identify that it is just already mapped on OSM. Repeat
until all of the objects mapped on OSM.

Using Zoom danMark feature on the Todo list Windows
Tags suitable for point object
Copying building related tags using Shift + R

• Example given above is for point object. When you find an object that is supposed to map as a
polygon, such as school complex which hasmore than one building inside, how tomap it onOSM?
Select the school object in the Todo list Windows and then click Zoom. Select the point object on
themap. Copy the tag to the building polygon alignedwith the point object by selecting the building
polygon and then clicking menu More tools → Copy tags from previous selection or pressing
Shift+Ronkeyboard. After copying the tags, delete tags that arenot related tobuildingand left only
building related tags. Draw a polygon covering all school area using Draw nodes, then copy tags
that are suitable for school area (tags that you deleted before in the building polygon) like amenity,
name and addr:full. After that, delete the school point from the survey data since it has just been
mapped as a school area polygon.

School point from survey data
Tags suitable for school building
Tags suitable for school area
6. Saving Changes

• If you have already done mapping using JOSM, save changes to OSM server because the newly
added objects are saved only in your computer. To save the changes you’vemade, click menu File
→UploadData.

Merging downloaded OSM data with survey data layer

Figure 13: Merging downloaded OSM data with survey data layer
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Adding satellite imagery on JOSM

Figure 14: Adding satellite imagery on JOSM

Changing the display of satellite imagery

Figure 15: Changing the display of satellite imagery

Inactivating Auto zoom for satellite imagery

Figure 16: Inactivating Auto zoom for satellite imagery

Satellite imagery layer andmerged survey data with downloaded data layer

Figure 17: Satellite imagery layer andmerged survey data with downloaded data layer

Filter Windows on JOSM

Figure 18: Filter Windows on JOSM

Adding filter string in the Filter Windows

Figure 19: Adding filter string in the Filter Windows

Newly added filter in the Filter Windows

Figure 20: Newly added filter in the Filter Windows

Using Zoom danMark feature on the Todo list Windows

Figure 21: Using Zoom danMark feature on the Todo list Windows

Tags suitable for point object

Figure 22: Tags suitable for point object

Copying building related tags using Shift + R

Figure 23: Copying building related tags using Shift + R

School point from survey data

Figure 24: School point from survey data

Tags suitable for school building

Figure 25: Tags suitable for school building

Tags suitable for school area

Figure 26: Tags suitable for school area
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UploadWindows on JOSM

Figure 27: UploadWindows on JOSM

Save OSM File Windows on JOSM

Figure 28: Save OSM File Windows on JOSM

• If you encounter warning/error after clicking Upload Data, it is better to fix warning/error first. You
can findoutmore about fixingwarning/error and commonwarning/errors found inSurveyDataVal-
idation Using JOSMmodule. However, if you don’t have the time to learn how to fix warning/error,
you can just go ahead and clickContinueUpload. UploadWindows will appear.

• If there is no warning/error, UploadWindows will appear. On the UploadWindows, type a brief com-
ment for the changes you’ve done in the comment box and specify the source(s) in the source box.
Type the name of the satellite imagery and survey in the source box. If you want other contributors
to review your edits, give a checkmark next to I would like someone to review my edits. Then
clickUploadChanges.

UploadWindows on JOSM
Note: You need to periodically upload your edits whenmapping so that there won’t be a hefty
amount of edits to upload. Themore edits youwant to upload, themore time it takes to upload.
If you already mapped a lot of edits and haven’t done any upload, you can upload it by chunk.
You can do it by clicking tab Advanced and select Upload data in chunks of objects in the
UploadWindows. Type theChunksizewithhowmanychangesyouwant touploadperchunk,
such as 500. This can be done to avoid incomplete upload, especially when your internet
connection is unstable that resulted in object duplication.

7. Saving .osmFile
• You can also save your editing layer by right clicking on your editing layer and click Save. Save
OSM fileWIndows shown below will appear. Type the name of your file, then click Save. Your file
will be saved in .osm format.

Save OSM File Windows on JOSM
Note: If you haven’t finished mapping your area and you want to continue mapping it later,
you can save your work as .osm file then you can continue mapping it later. You can open
your saved .osm file by clickingmenu File→Open, choose the file youwant to open and click
Open. After opening it, update the OSM data first by clicking menu File → Update Data and
you can go ahead to continue mapping.

8. Viewing Changes in theMap
• You can view your changes by checking it on OSM website and directing it to your mapping area.
Keep in mind, new changes can be viewed a while after uploading it to OSM server.

OSMmap before and after mapping process
SUMMARY
If you can apply and follow through to all of the steps mentioned in this module, then you are able to go
through OSM mapping process using JOSM successfully. You are able to do OSM mapping process,
such as downloading OSM data, adding satellite image, editing OSM data, uploading changes, saving
OSMdata as .osm file and viewing changes. You can upload your changes periodically, such as by region
or by village. If you already have finished conducting survey in one regionor in one village, you canupload
it directly to OSM. This shall be done so that your survey data is not piled up and others can perform data
validation for your edits.

OSMmap before and after mapping process

Figure 29: OSMmap before and after mapping process
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